1.6 Supported Browsers

Supported Browsers

 
Clarizen is tested on and supports the following web browser versions:

 

Browser Supported Versions Comments
Internet Explorer 11  Compatibility mode is not supported
Microsoft Edge The latest officially supported version  
Chrome The latest officially supported version  IE Tab is not supported
FireFox The latest officially supported version  
Safari The latest officially supported version  Mobile Safari is not supported

 

 

Have more questions? Submit a request

Comments

  • Avatar
    David Goulden

    Article updated for clarity around Internet Explorer versions.

Powered by Zendesk