Post

3 followers Follow
0
Avatar

Lifecycle - Users with License type ‘None’ cannot have ‘Financial Permissions’ special permissions

When using the REST API to disable users I get the error indicated in the title.  I suppose the only option is to try and programmatically remove the special permission first?

Kurt Kremer Answered

Official comment

Avatar

Hi Kurt,

Can you please share the request you are sending?

 

Thanks

Elad Franklin

Please sign in to leave a comment.

4 comments

0
Avatar

{'Ids': ['/User/491wo29yjvp1so2x0nwxbpknw15372'], 'Operation': 'Disable'}

I've since manually removed the special permission, and then the POST (of the above) works ok.

Thanks.

Kurt Kremer 0 votes
1
Avatar

We had a similar problem during our integration.
It may be about the license type.

Before updating FinancialPermissions field you need to update the license type to FULL.
Then you can send another API req. to update FinancialPermission field.
And then you can revert back to license type.

It worked us like this way.
Hope it helps.

Mustafa Kipergil 1 vote
-1
Avatar

Thanks Mustafa.

I will give this a try.  If I have further issues I'll reply back.

Kurt Kremer -1 votes