2 followers Follow

ClarizenClient V2.0 won't work

I am studying methods of control Clarizen via API web service. I prepared Visual Studio Express 2013 and inplemented wdsl following Clarizen web site.
I succeeded to run ClarizeClient v1.0 at first, then tried to run ClarizenClientv2.0.
I replaced wdsl for v2.0 and make project using ClarizenClientv2.0.
The result was bad. I could lig in and see the first screen with 4 buttons normally, but after pushing any buttons of this screen a error message as below appeared.
Please let me know waht was wrong?

追加情報:The formatter threw an exception while trying to deserialize the message: There was an error while trying to deserialize parameter The InnerException message was 'Error in line 1 position 440. Element '' contains data from a type that maps to the name ''. The deserializer has no knowledge of any type that maps to this name. Consider using a DataContractResolver or add the type corresponding to 'MyWorkItemsQuery' to the list of known types - for example, by using the KnownTypeAttribute attribute or by adding it to the list of known types passed to DataContractSerializer.'. Please see InnerException for more details.

Yasumitsu Honda

Yasumitsu Honda Answered

Please sign in to leave a comment.

1 comment


Hi Yasumitsu,
I tried it myself and had no issues using MyWorkItemsQuery with API2. I suspect the issues you experience may be due to the fact you replaced the WSDL, so you may have some leftovers from API1. Did you try starting a fresh Visual Studio project with API2 only?
If you still can't get it to work, please send your sample project to me (, and I'll try to figure out.
Hope this helps,

Ophir Kenig 0 votes
Comment actions Permalink